博文 | Qt for Python 5.11 发布了

 

本文翻译自  Qt for Python 5.11 released

原文作者:Alex Blasche,研发高级经理

校审: Richard Lin

我们很高兴地宣布首次正式发布Qt for Python (Pyside2)

正如版本号所表达的,它基于Qt 5.11,因此是第一个支持Qt 5系列的版本。总体而言,该项目将跟随通用的Qt发布计划和版本。尽管这仍然是一个技术预览版,但我们将使用常规的支持模式(兼容性模式除外)来支持这个版本。但是,不会支持Qt 5.11之前的版本。它同时适用于Qt for Application Development的开源版和商业版用户。请注意,商业版和开源版用户将共用一个软件包。我们期待能收到更多大家的反馈,哪些好用、哪些不好用,并尽早、更更及时地提供升级更新版本。

我们的最终目标是在发布Qt for Python 5.12时取消技术预览的标签。

Qt for Python的开发

这个版本的开发是一个漫长的过程:两年前,Lars (译者注:Qt公司CTO、Qt开源项目维护官)发布的一个声明(标题为Bringing Pyside back to Qt Project)。从那天起,我们经历了不少起起落落。作为第一步,我们必须解决许可证问题。在这个过程中,我们非常感谢项目贡献者对我们的支持和协作。

对于Qt for Python的内部开发团队而言,初始开发基于Qt 5.6,主要集中于稳定代码库。随着(当时)即将发布的Qt 5.7版本,它需要C++ 11支持,我们的绑定生成器Shiboken需要有重大更新。与qdoc和Qt Creator使用的方法类似,我们对C++进行解释然后用clang编译。另一项主要工作是编写文档。大家可能知道,文档生成流程比Qt要长得多。它要求我们重新激活qdoc中失传已久的遗留代码。尽管如此,我们并没有因此放弃进一步简化的工作。

今年早些时候,我们开始生成snapshot,非常感谢社区中早期使用者的所有评论和bug报告。自然,我们将继续发布snapshot。另一个方面是撰写系列技术博文,解释项目用法(以下按时间顺序):

最后一个里程碑是采用Python稳定的ABI。它使我们能够显著减少包的数量,因为同一个包可以处理所有Python 3.5和以后的版本。

获取 Qt for Python

这个版本支持三种主流桌面操作系统上的Python,版本包括 2.7、3.5和3.6。这些软件包可以从download.qt.io或使用pip命令获得。

最后,我们希望可以将软件包上传到https://pypi.org/project/PySide2/上的Python包索引服务(PyPi)。不过,PyPi上的包大小限制问题未能在发布前及时解决。

如您要报告Bug,请使用bugreports.qt.io上的Qt for Python项目。可以在Freenode #qt-pyside上联系该团队,他们会在每周会议纪要中定期公布进展。

其他相关链接:

The post Qt for Python 5.11 发布了 appeared first on Qt Chinese blog.

 

Previous
小课堂 | 如何用Qt Design Studio打造汽车仪表盘(第一部分)
小课堂 | 如何用Qt Design Studio打造汽车仪表盘(第一部分)

用Qt Design Studio设计您的汽车仪表盘界面。 设计师与开发者之间的工作关系可能很复杂,他们总像在说两种不同的语言。这种情况将一去不复返了!Qt的工具让设计师和开发者之间的合作比以往任何时候都更加容易而...

Next Article
Qt for Python | Qt的官方Python组件
Qt for Python | Qt的官方Python组件

Python for Qt是Qt的官方 Python组件,允许在Python应用程序中使用Qt API。在Qt公司的支持下,Python开发者能充分发挥Qt的潜力。